As you may know, Excel spreadsheets are a great way to store and analyze data. Generally, spreadsheets are made up of cells with a combination of numbers and text. To better understand your data, you need to know how to differentiate cells with text. So in this article you are going to learn how to count cells containing text in Excel. Is easier than it looks like.

How to count cells with text in Excel

Whether on Windows, Mac, or mobile, the process of counting cells with text in Excel is identical. To do this, the only thing you need to know is to use the formula COUNT YES.

The syntax is simple:

=CONTAR.SI(rango; criterio)

As you can see, the formula is very simple and easy to use.

In the range you have to put the cells that you want to verify, while in the criteria it is the type of data to filter. Perhaps, said like this, it may not be understood, but with the following example you will see everything much easier:

example cells with text

To count the cells that contain text in the image above and have the amount appear in a cell, you must first select a blank cell and write the function =COUNT.IF(range; criteria).

In the range you have to specify the cells you want to check. Write the first and last cell separated by a colon. In our example we want to check cells A1 through G10, so we’ll put A1:G10.

YOU CAN ALSO READ:   Microsoft Office Click-To-Run: Why The Process Loads The System And How To Deal With This?

For criteria we will write “*”, which is a wildcard of any data type. That way it will count only the cells that match that criteria, which is the same as any cell that contains data/text. So the complete formula would look like this =COUNT.IF(A1:G10;»*»)

Finally, press the Enter key to apply the formula.

count cells with text in excel

As you can see in the image above, we have used cell C12 to insert the formula and display the cells that contain text from the range A1:G10. Once the formula is applied with the Enter key, the result is as follows:

result cells with text

If you look closely, in the result it has only counted the cells that contain text, which are all the ones that say “TextoNumero” (30 cells) and the cells with the letters “I”, “S”, “L”, “A” , “B”, “I”, “T” (7 cells), making a total of 37 cells with text.

Obviously, with this formula you can count a lot of data depending on the criteria you specify. The criteria can

Now count cells with only numbers

Now, as we said at the beginning, with the formula above you count all the cells that contain data/text, where the numbers are also text. And what if you want to count the ones that contain numbers?

This can be done using the formula =COUNTIF(A1:G10), as shown in the image below. Note that Excel also counts dates as numbers.

count cells with number in excel

Write A Comment